This article contains ways to trouble-shoot common error codes in Lumen OHM.
Issue
Either of the following error codes display after a course is migrated to Lumen OHM
A. “Security parameters for the external tool MyOpenMath need to be set in Course Settings”
B. “Invalid consumer - your LTI tool is not configured correctly. Check your LTI key and secret displays when opening an assignment
Cause
An LTI configuration at the course level is blocking the key and secret at the account level.
Solution
1. Select the course and click on Settings
2. Once in Settings, click on the External Apps tab
3. Once in the Apps tab, scroll through to find any MyOpenMath apps that are not locked (no lock icon).
4. Click on gear icon to the right of the unlocked app, select delete to remove the app.
5. Error code should no longer appear. If you still receive the error message, please submit a support ticket at support.lumenlearning.com